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1 Getting Started
Welcome to the User’s Guide for the KODAK 305 Photo Printer 
Driver for MICROSOFT WINDOWS Operating Systems. The 
printer driver provides access to the printer features.

About the Printer Driver
With the 305 Printer Driver, you can access the printer specific 
features from your software applications. For example, your 
application determines the page breaks, font selection, and page 
setup for your print job. The printer driver translates this 
information into a printer ready output and sends the print job to 
the printer. The printer driver gives you additional printing options 
that may not be available from your software application.

Features of the Printer Driver
The printer driver provides the following printing options that may 
not be available directly from your software application:

• Color Management—You can make prints using the default 
color settings, then adjust the color, brightness, contrast, and 
saturation.

• Layout—Choose layout options such as orientation, number 
of copies, sharpening, and scaling. 

• Print Speed—Choose from a standard print speed to ultra fine 
for a higher print quality.
September 2020 1-1



Getting Started
Hardware and Software Requirements
You must have the following:

• MICROSOFT WINDOWS 7, MICROSOFT WINDOWS 8, or 
MICROSOFT WINDOWS 10 (latest service pack version 
available).

• Minimum main storage memory and hard disk capacity must 
be 512 Mb or more.

• A USB cable that is 2M or shorter.

• Available USB port (USB 1.1 and USB 2.0 protocol 
compatible).

Select the appropriate printer driver for your operating system.
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2 Installing and Uninstalling the Printer 
Driver

The following installation instructions assume that you are 
familiar with MICROSOFT WINDOWS Operating Systems and 
terminology.

Installing the Printer Driver
You must have “administrator” privileges to add a printer. 
IMPORTANT: Before installing the software, you must have the latest 

printer firmware version installed on your printer.

If you have an older version of the printer driver, you 
must uninstall the older version. See “Uninstalling the 
Printer Driver” on page 3.

1. Go to www.kodakalaris.com/go/rss.

2. Select:

• the Retail System Solutions tab

• Printers/Media
• Standalone Printer Support

3. Select the link for the 305 Photo Printer and download the 
correct printer driver.

4. Locate the file that you downloaded to your hard drive and 
double-click the file.

5. When the WinZip Self-Extractor screen appears, browse to a 
folder location that is easy to access, such as your computer's 
desktop. Click Unzip.

An Installer folder is created containing all of the files.

6. Complete the installation. See page 2-2
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Installing and Uninstalling the Printer Driver
Installing the Printer 
Driver on a WINDOWS 7, 
WINDOWS 8, or 
WINDOWS 10 Operating 
System

IMPORTANT: Make sure that you disconnect the printer from the 
computer before you install the printer driver.

1. Log on to your computer as an “Administrator” or 
“Administrator group members”.

2. Navigate to the folder where you saved the printer driver file.

3. Double-click Install_Drv.exe.

4. At, “Welcome to the Installer”, click Next.

5. At the license agreement, select:

• I accept this agreement.

• Next
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Installing and Uninstalling the Printer Driver
6. Click Finish.

7. Connect the printer to the computer.

8. Move the power switch for the printer to the On ( | ) position.

The driver software is automatically installed.

9. Click the balloon to check the installation status.

Uninstalling the Printer Driver
Before you remove the printer driver, make sure that:

• the printer driver is not being used by an application.

• there are no jobs waiting to be printed.

• if you are using the printer with WINDOWS 7 Operating 
Systems, make sure that the printer is not set as the default 
printer.

• if you uninstall and then reinstall the printer driver, make sure 
that you restart the computer after you reinstall the printer 
driver.
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Installing and Uninstalling the Printer Driver
Uninstalling the Printer 
Driver on a WINDOWS 7 or 
WINDOWS 10 Operating 
System

You must have “administrator” privileges to remove a printer. 

1. Select Start > Control Panel > Devices and Printers.

2. Click the icon for the KODAK 305 Photo Printer.

3. Right-click and select Remove Devices.

4. Click Yes at the message prompt.

5. From the “Devices and Printers” window, click the icon for the 
MICROSOFT XPS Document Writer or any other printer.

6. Click Print Server Properties.

7. Select the “Drivers” tab.

8. Click Change Driver Settings.

9. Select the printer driver that you want to remove.

10. Click Remove.

11. At, “Remove Driver And Package”:

• Select “Remove driver only.”

• Click OK.

12. At, “Printer Server Properties”, click Yes.

13. If “Driver package information collected” appears, click 
Delete.

14. At, “Driver package deleted”, click OK.

15. Confirm that the driver is removed:

• Select Start > Control Panel > Programs and Features
• Right-click Windows Driver Package –KODAK 305 Photo 

Printer.

• Select Uninstall/Change.

• Make sure that the printer driver is removed.

16. Disconnect the USB cable from the printer.

17. Restart the computer.
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Installing and Uninstalling the Printer Driver
Uninstalling the Printer 
Driver on a WINDOWS 8 
Operating System

You must have “administrator” privileges to remove a printer. 

1. On the keyboard, press the WINDOWS “START” Key and “C”. 

2. Select Settings > Control Panel > Devices and Printers.

3. Click the icon for the KODAK 305 Photo Printer.

4. Right-click and select Remove Devices.

5. Click Yes at the message prompt.

6. From the “Devices and Printers” window, click the icon for the 
MICROSOFT XPS Document Writer or any other printer.

7. Click Print Server Properties.

8. Select the “Drivers” tab.

9. Click Change Driver Settings.

10. Select the printer driver that you want to remove.

11. Click Remove.

12. At, “Remove Driver And Package”:

• Select “Remove driver only.”

• Click OK.

13. At, “Printer Server Properties”, click Yes.

14. If “Driver package information collected” appears, click 
Delete.

15. At, “Driver package deleted”, click OK.

16. Confirm that the driver is removed:

• Select Settings > Control Panel > Programs and Features
• Right-click Windows Driver Package –KODAK KODAK 

305 Photo Printer.

• Select Uninstall/Change.

• Make sure that the printer driver is removed.

17. Disconnect the USB cable from the printer.

18. Restart the computer.
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3 Using the Printer Driver with the 
WINDOWS Operating System

This section describes how to use the printer driver to send print 
jobs to the KODAK 305 Photo Printer from your computer.

Changing Print Options from an Application
You can use the Printing Preferences dialog box to select print 
options from an application.

1. In your application, select Print from the File menu.

2. Depending on the application, click Properties or Setup in the 
Print dialog box.

3. Select options from the tabs in the Printing Preferences dialog 
box (shown on the following pages), then click:

• OK—to save your selections and close the dialog box

• Cancel—to cancel your selections and close the dialog box

• Apply—to save your selections without closing the dialog 
box

4. Depending on the application, click OK or Print in the Print 
dialog box.
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Using the Printer Driver with the WINDOWS Operating System
Selecting the Options on 
the Paper Tab

You can select the following options on the Paper tab:

• Paper Size—the size of paper.

NOTE: When you select a Paper Size, the following change 
depending on the paper size that you select:

– Print Pixel—the number of dots/pixels per inch. The 
print pixel number varies depending on the paper size.

– Print Size—the print size.

Available Print Sizes:

Print Size Image Size

2 x 6 in. (51 x 152 mm) 624 x 1864 pixels

2 x 6 in. x 2 Type 1 (51 x 152 mm x2) 1218 x 1864 pixels

2 x 6 in. x 2 Type 2 (51 x 152 mm x2) 609 x 1864 pixels

3 x 5 in. (76 x 127 mm) 926 x 1568 pixels

3 x 5 in. x 2 Type 1 (76 x 127 mm x 2) 1568 x 1888 pixels

3.5 x 5 in. (90 x 130 mm) 1076 x 1568 pixels

3.5 x 5 in. x 2 Type 1 (90 x 130 mm x 2) 1568 x 2190 pixels

3 x 6 in. (76 x 152 mm) 926 x 1864 pixels

3 x 6 in. x 2 Type 1 (76 x 152 mm x 2) 1864 x 1888 pixels

4 x 6 in. (102 x 152 mm) 1218 x 1864 pixels

4 x 6 in. x 2 Type 1 (102 x 152 mm x 2) 1864 x 2454 pixels

5 x 5 in. (127 x 127 mm) 1524 x 1568 pixels

5 x 7 in. (130 x 180 mm) 1568 x 2128 pixels

6 x 6 in. (152 x 152 mm) 1820 x 1864 pixels

6 x 8 in. (152 x 203 mm) 1864 x 2422 pixels

6 x 8 in. (152 x 203 mm) border 1536 x 2126 pixels
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Using the Printer Driver with the WINDOWS Operating System
Type 1 Example—To print a 2 x 6 in. Type 1 (51 x 152 mm x 2) 
print, a 4 x 6 in. image sent to the printer, resulting in the 
printer automatically cutting the 4 x 6 in. print into two 2 x 6 
in. prints. To use this mode, compose two 2 x 6 in. images on 
one 4 x 6 in. layout. This is necessary when the program is 
unable to send two different images simultaneously to the 
printer.

Type 2 Example—To print a 2 x 6 in. Type 2 (51 x 152 mm x 2) 
print, two different 2 x 6 in. images can be sent 
simultaneously to printer. The printer prints two 2 x 6 in. 
prints using one 4 x 6 in. paper sheet. If just one 2 x 6 in. 
image is sent to the printer, the printer prints it along with a 
blank sheet.

• Orientation
– Portrait—orients the print vertically.

– Landscape—orients the print horizontally.

• Copies—the number of copies to print.

• Scaling—scales a print by a specified percentage.

• Saver Mode
– Media Saver—does a ribbon rewind to use unclaimed 

patches on the ribbon.

– Time Saver—saves print time compared to Media Saver 
mode.

• Remain—the remaining amount of ribbon in the printer to 
produce 4 x 6 in. prints. The number of prints remaining on 
the ribbon depends on the paper and print size selected.

• About—display driver information.
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Using the Printer Driver with the WINDOWS Operating System
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Using the Printer Driver with the WINDOWS Operating System
Setting the Options on the 
Options Tab

You can select the following options on the Options tab:

• Sharpness—sets an amount of None, -3 Soft, -2, -1, 0 Normal, 
1, 2, 3 Hard image enhancement to improve the sharpness of 
the print.

• Print Speed
– Fine—standard print speed for standard print quality.

– Ultra Fine—slower print speed for high print quality. Ultra 
Fine is only available on printers with the latest firmware.

• Print Finish—select print finish.

• Color Matching—select to use the ICC profile on the Color 
Management tab in the application that you are using. Color 
matching may not be available with some applications.

• Defaults—all settings on the Option tab are reset to the 
default settings.
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Using the Printer Driver with the WINDOWS Operating System
Setting the Options on the 
Color Adjust Tab

You can select the following options on the Color Adjust tab:

• Brightness—adjusts the relative lightness or darkness.

• Contrast—adjusts the relationship between the light areas, 
midtones, and dark areas.

• Saturation—adjusts the intensity of the colors.

• Gamma—adjusts the lightness or darkness of the midtones.

• Red—adds or subtracts red.

• Green—adds or subtracts green.

• Blue—adds or subtracts blue.

• Load—load the color adjust settings.

• Save—save the color adjust settings.
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Using the Printer Driver with the WINDOWS Operating System
Checking the Color Profile
The printer driver package includes the profile “Kodak 305 
Printer_2016.icm” that can be used in both Fine and Ultra fine 
Modes. The profile is automatically associated with the 305 
Printer when the driver is installed. To make sure this profile is 
being used:

1. Select Print Menu > Print… > Options > Color Management.

2. From the Device pull-down menu, check that “KODAK 305 
Photo Printer” is selected.

3. Verify that the:

• ICC Profile is listed as “Kodak 305 Printer 2016 Fine and UF 
v2.4b.”

• File name is listed as “Kodak 305 Printer_2016.icm.” 

4. To make sure the correct profile is always used, select:

• “Manual” as the Profile selection

•  “Use my setting for this device”

Adding a Color Profile
1. Install the profile in the folder: 

C:\Windows\System32\spool\drivers\color
2. Right-click the profile.

3. Select “Install Profile”.

4. Select “Add...” from the Color Management Window.

5. Select the profile from the “Associate Color Profile” Window.
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Using the Printer Driver with the WINDOWS Operating System
Removing a Color Profile 1. To remove a color profile, select the profile in the “Color 
Management” Window.

2. Select Remove > Continue.
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4 Troubleshooting

Printer Error Messages
The printer driver uses the standard error handling provided by 
the operating system. Error messages are displayed with the 
spooler status window (printer queue). 
NOTE: When an error occurs during printing, it may appear on 

the monitor. Check the operator control panel for 
additional information.

Number Problem/Error Message Description or Causes Solution

1 The printer is not 
connected.

The printer driver cannot 
connect to the printer.

Check that the printer power is on 
and that the printer is connected to 
your computer.

2 The printer does not 
respond.

---- • Click OK. 
Turn the printer off and then back 
on. 

• If problem persists, contact 
KODAK Service and Support.

3 Something is wrong with 
the printer. (XXXXXX).

---- • Click Cancel. 
Turn the printer off and then back 
on. 

• If problem persists, contact 
KODAK Service and Support.

4 Mechanical 
Error(XXXXXX). 
Set paper again.

• Out of paper

• Paper is partially 
loaded

• Paper ran out while 
loading

Load paper or check that the paper 
is installed properly.

5 Mechanical 
Error(XXXXXX). 

---- • Click Cancel. 
Turn the printer off and then back 
on. 

• If problem persists, contact 
KODAK Service and Support.

6 Printing unit is opened. The print unit is opened. Check the operator control panel 
for additional information and close 
the print unit.

7 Printing unit is opened 
while printing.

The print unit is opened. Check the operator control panel 
for additional information and close 
the print unit.
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Troubleshooting
Number Problem/Error Message Description or Causes Solution

8 Ribbon and paper type do 
not match.

Ribbon and paper 
mismatch.

Load the correct ribbon and paper.

9 Ribbon is not correctly 
installed.

• Out of ribbon

• Ribbon is partially 
loaded

Load ribbon or check that the 
ribbon is installed properly.

10 Ribbon end. Out of ribbon. Load ribbon or check that the 
ribbon is installed properly.

11 Paper empty. • Out of paper

• Paper is partially 
loaded

• Paper ran out while 
loading

Load paper or check that the paper 
is installed properly.

12 The Ribbon is not standard. The printer cannot 
determine the type of ribbon 
that is loaded.

Load the correct ribbon.

13 The printer was turned off 
while printing.

The printer was turned off 
while printing.

Move the power switch for the 
printer to the on ( | ) position.

14 Paper jam(XXXXXX). Set 
paper again.

A paper jam has occurred. Check the operator control panel 
for additional information and clear 
the paper jam.

15 Paper size of printer driver 
and Ribbon type do not 
match.

Ribbon and paper 
mismatch.

Load the correct ribbon and paper.

16 Ribbon empty. Replace 
Ribbon.

Out of ribbon. Load ribbon or check that the 
ribbon is installed properly.

17 Paper end. Out of paper. Load paper or check that the paper 
is installed properly.

18 The printer not equipped 
with the Trim tray.

The trim tray is not installed. Install the trim tray.

19 Ribbon error. (XXXXXX). • Out of ribbon

• Ribbon is partially 
loaded

Load ribbon or check that the 
ribbon is installed properly.

20 Ribbon error. (XXXXXX). 
Set paper and Ribbon again.

• Out of paper or ribbon

• Paper or ribbon is 
partially loaded

• Paper or ribbon ran out 
while loading

• Load ribbon or check that the 
ribbon is installed properly.

• Load paper or check that the 
paper is installed properly.
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